Degraded Search Performance in EU

Incident Report for Dust

Resolved

This incident has been resolved
Posted May 05, 2026 - 10:09 UTC

Update

We are continuing to investigate this issue.
Posted May 05, 2026 - 09:25 UTC

Investigating

We are currently experiencing degraded performance affecting search functionality in the EU. Users may experience slow responses or timeouts when performing searches.
Our team is actively investigating and working to resolve the issue.
Posted May 05, 2026 - 09:25 UTC
This incident affected: Regions (europe-west1) and Dust Application (Data Sources).