Error when navigating Dust

Incident Report for Dust

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 13:39 UTC

Identified

Some users are seeing an error message when navigating the Dust website.
Posted Jul 24, 2026 - 13:35 UTC
This incident affected: Dust Application (Conversations, Chrome Extension), Dust Developer Platform (Dust App Platform), and Regions (europe-west1, us-central1).