Degraded performance of Dust platform

Incident Report for Dust

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 10:24 UTC

Identified

High latency on our authentication service are slowing down the whole platform.
The issue has been identified and we are working on solving it.
Posted Jul 16, 2026 - 08:21 UTC
This incident affected: Dust Application (Conversations, Chrome Extension), Dust Developer Platform (Dust App Platform, API), and Regions (europe-west1, us-central1).